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Abstract: This paper discusses the stresses developed in the
pressure vessels having various thicknesses. Pressure vessels are
intended to hold gases or liquids at a pressure substantially
different from atmospheric pressure. Equations of static
equilibrium along with free body diagrams will be used to
determine the normal stress ¢1 in the hoop direction and 62 in the
longitudinal direction also the von misses’ stresses. Also we will
discuss the deformations and displacements to the pressure vessel
using commercial finite element software called ANSYS for
modelling and analyzing of the vessels. And the main results we
found is that there is stress and deformation variation in the vessel
according to thickness.
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I. INTRODUCTION

pressure vessel is defined as a container with a pressure

differential between inside and outside. The inside
f/internal pressure is usually higher than the outside, except for
some isolated situations.

Pressure vessels are compressed gas storage tanks intended to
hold gases or liquids at a pressure substantially different from
the ambient pressure. The analysis of pressure vessels
encompasses many combinations of stresses. The safe design,
installation, operation, and maintenance of pressure vessels are
in accordance with codes such as American Society of
Mechanical Engineers boiler and pressure vessel code.
Longitudinal and hoop stresses are produced due to internal
pressure and variable bending stress due to bending moment
caused by wind loads. Therefore, a designer has to keep all the
probable loads and moments on a pressure vessel [1].

Tanks, vessel and pipelines that carry, store or receive fluids
are called pressure vessel. A pressure vessel is defined as a
container with a pressure differential between inside and
outside. The inside pressure is usually higher than the outside.
The fluid inside the vessel may undergo a change in state as in
the case of steam boiler or may combine with other reagent as
in the case of chemical reactor. Pressure vessel often has a
combination of high pressure together with high temperature
and in some cases flammable fluids or highly radioactive
material. Because of such hazards it is imperative that the
analysis be such that no leakage can occur. Pressure vessels are

usually spherical or cylindrical with dome end. The cylindrical
vessels are generally preferred because of the present simple
manufacturing problem and make better use of the available
space. Boiler, heat exchanger, chemical reactor and so on, are
generally cylindrical [2].

In paper we will focus on cylindrical pressure vessels. And they
are of two types namely

Thin-walled cylindrical and thick-walled cylindrical pressure
vessels.

1.1 Thin Walled Cylindrical Pressure Vessel

If the wall thickness is less than about 7% of the inner diameter,
then the cylinder may be treated as a thin one. Thin walled
cylinders are used as boiler shells, pressure tanks, pipes and in
other low pressure processing equipment. In general, three
types of stresses are developed in pressure cylinders viz.
circumferential or hoop stress, longitudinal stress in closed end
cylinders and radial stresses. These stresses are demonstrated
in figures below
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Fig.1.1.1 a) Circumferential stress b) Longitudinal stress and c¢) Radial

In a thin walled cylinder, the circumferential stresses may be
assumed to be constant over the wall thickness and stress in the
radial direction may be neglected for the analysis. Considering
the equilibrium of a cut out section the circumferential stress o,

and longitudinal stress ¢ can be found.
4

Consider a section of thin cylinder of radius r, wall thickness t
and length L and subjected to an internal pressure p as shown
in figure-1.1.1 (a). Consider now an element of included angle
do at an angle of 8 from vertical. For equilibrium we may write
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Considering a section along the longitudinal axis as shown in
figure-1.1.1. (b) we may write
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Fig-1.1.2 (a) Circumferential stress in a thin cylinder (b) Longitudinal stress
in a thin cylinder &

1.2 Thick-Walled Pressure Vessels

A thick walled pressure vessel is generally considered to be one
of whose walls are greater than about 1/20 of the radius of the
vessel. Remember that a catastrophic failure of the vessel could
result in serious injury or death. [,

For thick cylinders such as guns, pipes to hydraulic presses,
high pressure hydraulic pipes the wall thickness is relatively
large and the stress variation across the thickness is also
significant. In this situation the approach made in the previous
section is not suitable. The problem may be solved by
considering an axisymmetric about z-axis and solving the

differential equations of stress equilibrium in polar co-ordinates
51

Consider a thick walled cylinder with open ends as shown
above. It is loaded by internal pressure Pi and external pressure
Po as seen below. It has inner radius ri and outer radius ro.

Fig-1.2.1 Thick walled pressure vessel

When calculating the strains and stresses of the pressure
vessel we use the formula below
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Giving the stresses as a function of radius in equation 4 and 5
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(b) External Pressure only (Pi= 0): then we get equation 8 and
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These are known as simplified Lame’s equations [6].
I1. BACKGROUND

Pressure vessels used in industry are leak-tight pressure
containers, usually cylindrical or spherical in shape, with
different head configurations. They are usually made from
carbon or stainless steel and assembled by welding. Early
operation of pressure vessels and boilers resulted in numerous
explosions, causing loss of life and considerable property
damage. Some 80 years ago, the American Society of
Mechanical Engineers formed a committee for the purpose of
establishing minimum safety rules of construction for boilers.
In 1925 the committee issued a set of rules for the design and
construction of unfired pressure vessels.

Structures such as pipes or bottles capable of holding internal
pressure have been very important in the history of science and
technology. Although the ancient Romans had developed
municipal engineering to a high order in many ways, the very
need for their impressive system of large aqueducts for carrying
water was due to their not yet having pipes that could maintain
internal pressure. Water can flow uphill when driven by the
hydraulic pressure of the reservoir at a higher elevation, but
without a pressure-containing pipe an aqueduct must be
constructed so the water can run downhill all the way from the
reservoir to the destination. Airplane cabins are another
familiar example of pressure-containing structures. They
illustrate very dramatically the importance of proper analysis,
since the atmosphere in the cabin has enough energy associated
with its relative pressurization compared to the thin air outside
that catastrophic crack growth is a real possibility.
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A number of fatal commercial tragedies have resulted from this,
particularly famous ones being the Comet aircraft that
disintegrated in flight in the 1950’s and the loss of a 5-meter
section of the roof in the first-class section of an Aloha Airlines
B737 in April 1988. [ 7]

2.1 Materials

The materials to be used in pressure vessels must be selected
from Code-approved material specifications. This requirement
is normally not a problem since a large catalogue of tables
listing acceptable materials is available. Factors that need to be
considered in picking a suitable table are:

e Cost

e  Fabricability

e Service condition (wear, corrosion, operating
temperature)

e Availability and Strength requirements. [8]

I11. ANSYS CASE STUDY: AXISYMMETRIC ANALYSIS
OF A VERTICAL PRESSURE VESSEL

The pressure vessel shown below is made of stainless steel (E
= 2*10° Pa, v = 0.3) and contains an internal pressure of p =
4000 pa. The cylindrical vessels have inner diameters of 180
mm and 160 mm and thicknesses of 10mm and 20 mm for thin
and thick cylinders respectively.

3.1 Formulation using ANSYS

Start > Programs > ANSYS Mechanical APDL Product
Launcher

Utility Menu >File >Change Job name...> Enter ‘Pressure
Vessel’ > OK

Utility Menu > File >Change Title... > Enter ‘Stress Analysis
of an Axisymmetric Pressure Vessel’ > OK

ANSYS Main Menu > Preferences > Preferences for GUI
Filtering >Select ‘Structural’ and ‘h-method’ > OK

3.2 Enter the Preprocessor to define the model geometry and
do up to post processor

3.2.1 Thin-walled pressure vessel

Define Element Type (Axisymmetric Option) and Material
Properties.

ANSYS Main Menu > Preprocessor > Element Type >
Add/Edit/Delete > Add... > Structural Solid 8 node 183
(PLANE183) (define ‘Element type reference number’ as 1) >
OK > Click Options... > Select ‘Axisymmetric’ for K3
(Element behavior) > OK > Close

ANSYS Main Menu > Preprocessor > Material Props >
Material Models > Double Click Structural > Linear > Elastic
> |sotropic > Enter 2e5 for EX and 0.3 for PRXY > Click OK
> Click Exit (under ‘Material’) and Begin creating the
geometry by defining the keypoints
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ANSYS Main Menu Preprocessor > Modeling >
Create>keypoints>in active coordinate system.
Table 1: shows the key points of thin pressure vessel
K1(0,0) apply K2 (100,0) apply
K3(100,300) apply k4(20, 330) apply
k5(20, 350) apply k6(10,350) apply
k7(10,290) apply k8(90,290) apply
k9(90.10) apply k10(0,10) ok
After creating Keypoints then create the area
ANSYS Main Menu Preprocessor > Modeling >

Create>areas>rectangles>through keypoints then connect the
keypoints by area>ok

Then we mesh the finer meshing

ANSYS Main Menu Preprocessor >Meshing>mesh tool>tick
smart size>reduce to fine mesh of 3>mesh>pick all.

Now applying The loading boundary conditions

ANSYS Main Menu processor(solution)>Analysis type>tick
new.

ANSYS Main Menu processor(solution)>Define
load>apply>structural>displacement > on lines >select UY to
support vertical reaction,

ANSYS Main Menu processor(solution)>Define
load>apply>structural>pressure>on lines>enter 4000pa>ok.

After applying the loads and boundary conditions we solve the
element

ANSYS Main Menu processor(solution)>solve>current
LS>when the solution is done>close the dialog boxes. After
completing the processing part, we may start the post processor

ANSYS Main  Menu General post processor>Plot
results>deformed shapes>tick def +undef>ok

ANSYS Main Menu General post processor>Plot
results>contour plots>Nodal sol>DOF>X component>ok
ANSYS Main  Menu General post processor>Plot
results>contour plots>Nodal sol>DOF>Y component>ok
ANSYS Main Menu General post processor>Plot
results>contour plots>Nodal sol>Displacement vector> ok
ANSYS Main Menu General post processor>Plot
results>contour plots>Element sol>stress>X stress
component>ok

ANSYS Main Menu General post processor>Plot
results>contour plots>Element sol>stress>Y stress
component>ok

ANSYS Main Menu General post processor>Plot
results>contour plots>Element sol>stress>Z stress
component>ok
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ANSYS Main Menu General post processor>Plot
results>contour  plots>Element  sol>stress>XY  stress
component>ok

ANSYS Main Menu General post processor>Plot
results>contour plots>Element sol>stress>von misses stress
>0k

The axisymmetric of the cylinder

Figure: 3.2.1.5 Displacement vector

-

Figure: 3.2.1.1 axisymmetric shape of the cylinder

Figure: 3.2.1.6 Full symmetry expansion

Analysis of stresses of the cylinder
Figure: 3.2.1.2 The loading and boundary conditions of the cylinder

The following are the results obtained in the analysis (Nodal
Solution)

Figure: 3.2.1.3 Nodal solution in x direction Figure: 3.2.1.7 stress in X direction

Figure: 3.2.1.4 Nodal solution in y direction Figure: 3.2.1.8 stress in Y direction
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Figure: 3.2.1.9 Von misses stress
3.2.2 Thick-walled pressure vessel

Define Element Type (Axisymmetric Option) and Material
Properties.

ANSYS Main Menu > Preprocessor > Element Type >
Add/Edit/Delete > Add... > Structural Solid 8 node 183
(PLANE183) (define ‘Element type reference number’ as 1) >
OK > Click Options... > Select ‘Axisymmetric’ for K3
(Element behavior) > OK > Close

ANSYS Main Menu > Preprocessor > Material Props >
Material Models > Double Click Structural > Linear > Elastic
> |sotropic > Enter 2e5 for EX and 0.3 for PRXY > Click OK
> Click Exit (under ‘Material”)

Begin creating the geometry by defining the keypoints

ANSYS Main Menu Preprocessor >
Create>keypoints>in active coordinate system

Modeling >

Table 2: Shows keypoints of thick pressure vessels

K1(0,0) apply K2 (100,0) apply
K3(100,300) apply k4(30, 330) apply
k5(30, 350) apply k6(10,350) apply
k7(10,310) apply k8(80,310) apply

k9(80.20) apply k10(0,20) ok
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After creating Keypoints then create the area

ANSYS Main Menu Preprocessor > Modeling >
Create>areas>rectangles>through keypoints then connect the
keypoints by area>ok. Then we mesh the area by finer meshing

ANSYS Main Menu Preprocessor >Meshing>mesh tool>tick
smart size>reduce to fine mesh of 3>mesh>pick all. And now
applying The loading and boundary conditions

ANSYS Main Menu processor(solution)>Analysis type>tick
new.

ANSYS Main Menu processor(solution)>Define
load>apply>structural>displacement > on lines >select UY to
support vertical reaction,

ANSYS Main Menu processor(solution)>Define
load>apply>structural>pressure>on lines>enter 4000pa>ok.
After applying the loads and boundary conditions we solve the
element

ANSYS Main Menu processor(solution)>solve>current
LS>when the solution is done>close the dialog boxes. After
completing the processing part, we may start the post processor

ANSYS Main Menu General post
results>deformed shapes>tick def +undef>ok

ANSYS Main Menu General post processor>Plot
results>contour plots>Nodal sol>DOF>X component>0k

ANSYS Main Menu General post processor>Plot
results>contour plots>Nodal sol>DOF>Y component>ok

ANSYS Main Menu General post processor>Plot
results>contour plots>Nodal sol>Displacement vector> ok

ANSYS Main Menu
results>contour
component>ok

ANSYS Main Menu
results>contour
component>ok

ANSYS Main Menu
results>contour
component>ok

ANSYS Main Menu
results>contour
component>ok

ANSYS Main Menu General post processor>Plot
results>contour plots>Element sol>stress>von misses stress
>0k

processor>Plot

General post processor>Plot
plots>Element  sol>stress>X  stress

General post processor>Plot
plots>Element  sol>stress>Y  stress

General post processor>Plot
plots>Element sol>stress>Z stress

General post processor>Plot
plots>Element  sol>stress>XY  stress

The loading and boundary conditions of the cylinder
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Figure: 3.2.2.1 Loading and the boundary condition

Figure: 3.2.2.5 Nodal solution in displacement vector form

Analysis of stresses in the cylinder

Figure: 3.2.2.2 The deformed shape of the vessel

The following are the results obtained in the analysis (Nodal
Solution)

Figure: 3.2.2.6 Stress component in X-direction

Figure: 3.2.2.3 The nodal solution in the X-direction
Figure: 3.2.2.7 Stress component in Y-direction

Figure: 3.2.2.4 The nodal solution in the Y-direction ] ] o
Figure: 3.2.2.8 Stress component in Z-direction
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13.Retrieved from
http://www.iaeme.com/IJMET .asp%0Ahttp://www.iaeme.com/JM
ET/issue.asp?JType=JMET&VType=3&IType=2

Figure: 3.2.2.9 Von misses stress

Table 3: Summary of results by considering maximum value

Thin walled pressure vessel Thick walled pressure vessel
Nodal Nodal solution
solution(mm) Stresses(pa) (mm) Stresses (pa)
16.2 inx 95204.3 in x . R 27166.5 in x
- g 7.2 in x direction L
direction direction direction
46.99 iny 170233 iny N 514385iny
direction direction 9.9iny direction direction
47.1 . 9.923 .
displacement 95853.1in Z displacement 22568.81n Z
direction direction
vector vector
173633 von 53908.5 von
misses misses

IV. CONCLUSION

1. Various parameters of Pressure vessels are analyzed
using ANSYS APDL.

2. The difference between the thin and thick pressure
vessels were classified.

3. Analysis of cylindrical pressure vessel were
performed and maximum stresses found by ANSYS
are presented in the postprocessor. It is concluded that
there are differences in resisting stresses in the thin
and the thick pressure vessel, we get the less
deformation in the thick one where as the large
deformation in the thin one.
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